# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(([A-F][0-9]|[0-9]{2}|[0-9][A-F]|[A-F]{2})|(\?))(\s|)/\\x$2/gm;t' <<< "81 F9 00 00 00 00 75 1D F3 0F 10 05 00 00 00 00 F3 0F 11 44 24 00 8B 44 24 18 35 00 00 00 00 89 44 24 0C EB 0B"