const regex = /(([A-F][0-9]|[0-9]{2}|[0-9][A-F]|[A-F]{2})|(\?))(\s|)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(([A-F][0-9]|[0-9]{2}|[0-9][A-F]|[A-F]{2})|(\\?))(\\s|)', 'gm')
const str = `81 F9 00 00 00 00 75 1D F3 0F 10 05 00 00 00 00 F3 0F 11 44 24 00 8B 44 24 18 35 00 00 00 00 89 44 24 0C EB 0B`;
const subst = `\\x$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);