// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(([A-F][0-9]|[0-9]{2}|[0-9][A-F]|[A-F]{2})|(\?))(\s|)").unwrap();
let string = "81 F9 00 00 00 00 75 1D F3 0F 10 05 00 00 00 00 F3 0F 11 44 24 00 8B 44 24 18 35 00 00 00 00 89 44 24 0C EB 0B";
let substitution = "\\\\x$2";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}