import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<timestamp>[JFMASOND][a-z]{2} [0123]\\d [012]\\d(?::[0-5]\\d){2}\\.\\d{6}\\b) (?P<levelname>[A-Z]) +(?:[A-Z]+: +)?(?:\\[+(?P<source>[A-Za-z]+)\\]+)? *(?P<message>.+)";
final String string = "Oct 25 14:24:29.700799 I [System] Connected\n"
+ "Oct 25 14:24:30.315344 E ERR: [[Signal]] Valid Shared Mem!\n"
+ "Oct 25 14:24:29.653900 D Connection refused\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}