const regex = new RegExp('^(?P<timestamp>[JFMASOND][a-z]{2} [0123]\\d [012]\\d(?::[0-5]\\d){2}\\.\\d{6}\\b) (?P<levelname>[A-Z]) +(?:[A-Z]+: +)?(?:\\[+(?P<source>[A-Za-z]+)\\]+)? *(?P<message>.+)', 'gm')
const str = `Oct 25 14:24:29.700799 I [System] Connected
Oct 25 14:24:30.315344 E ERR: [[Signal]] Valid Shared Mem!
Oct 25 14:24:29.653900 D Connection refused
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}