re = /^(?P<timestamp>[JFMASOND][a-z]{2} [0123]\d [012]\d(?::[0-5]\d){2}\.\d{6}\b) (?P<levelname>[A-Z]) +(?:[A-Z]+: +)?(?:\[+(?P<source>[A-Za-z]+)\]+)? *(?P<message>.+)/m
str = 'Oct 25 14:24:29.700799 I [System] Connected
Oct 25 14:24:30.315344 E ERR: [[Signal]] Valid Shared Mem!
Oct 25 14:24:29.653900 D Connection refused
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end