using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(.*>).*<\/\1";
string input = @"<p>Este é uma paragrafo</p>
<b>Este é uma paragrafo</b>
<b>Fechamento Incorreto<b>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}