re = /<(.*>).*<\/\1/m
str = '<p>Este é uma paragrafo</p>
<b>Este é uma paragrafo</b>
<b>Fechamento Incorreto<b>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end