$re = '/<(.*>).*<\/\1/m';
$str = '<p>Este é uma paragrafo</p>
<b>Este é uma paragrafo</b>
<b>Fechamento Incorreto<b>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);