#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(,\d)$"
Local $sString = "-2,3" & @CRLF & _
"45,5" & @CRLF & _
"3.000,0"
Local $sSubst = "${1}0"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)