$re = '/(,\d)$/m';
$str = '-2,3
45,5
3.000,0';
$subst = "${1}0";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;