import Foundation
let pattern = #"(,\d)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
-2,3
45,5
3.000,0
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"${1}0"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)