using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"FROM\ ([a-zA-Z_0-9]+)";
string input = @"SELECT * FROM wp_users WHERE user_login = 'username'";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}