re = /FROM\ ([a-zA-Z_0-9]+)/m
str = 'SELECT * FROM wp_users WHERE user_login = \'username\''
# Print the match result
str.scan(re) do |match|
puts match.to_s
end