$re = '/FROM\ ([a-zA-Z_0-9]+)/m';
$str = 'SELECT * FROM wp_users WHERE user_login = \'username\'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);