import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "href=\"([^\"\\']+)\"";
final String string = "<img class=\"alignnone size-full wp-image-15\" src=\"http://wp491.dev/wp-content/uploads/2017/12/wordpress-speaker.png\" alt=\"\" width=\"1600\" height=\"900\" />\n\n"
+ "<a href=\"http://wp491.dev/wp-content/uploads/2017/12/pdf.pdf\">pdf</a>\n\n"
+ "<a class=\"test\" href=\"https://maximeculea.fr/wp-content/uploads/2017/12/pdf.pdf\">pdf</a>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}