// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"href="([^"\']+)""#).unwrap();
let string = "<img class=\"alignnone size-full wp-image-15\" src=\"http://wp491.dev/wp-content/uploads/2017/12/wordpress-speaker.png\" alt=\"\" width=\"1600\" height=\"900\" />
<a href=\"http://wp491.dev/wp-content/uploads/2017/12/pdf.pdf\">pdf</a>
<a class=\"test\" href=\"https://maximeculea.fr/wp-content/uploads/2017/12/pdf.pdf\">pdf</a>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}