const regex = /href="([^"\']+)"/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('href="([^"\\\']+)"', 'g')
const str = `<img class="alignnone size-full wp-image-15" src="http://wp491.dev/wp-content/uploads/2017/12/wordpress-speaker.png" alt="" width="1600" height="900" />
<a href="http://wp491.dev/wp-content/uploads/2017/12/pdf.pdf">pdf</a>
<a class="test" href="https://maximeculea.fr/wp-content/uploads/2017/12/pdf.pdf">pdf</a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}