import Foundation
let pattern = #"^.*?\\n(.*?)\\n"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
"\nDeutsche Internationale Schule in Abu Dhabi\nP.O. Box 4150\nAbu Dhabi\nTelefon:\t00971-2-6668668\nTelefax:\t+ 971-2-6653107\nE-Mail-Schule:\tinfo@gisad.ae\nE-Mail VwLtr:\tdoris.boehm@gisad.ae\nE-Mail Vorstand:vv@gisad.ae\n\nInternet:\twww.gisad.ae\n\nZeitdifferenz (in Std.):\nSommerzeit:\t+2\nWinterzeit:\t+3\n\n2. Zuständige Auslandsvertretung:\nEmbassy of the Federal Republic of Germany\nP.O.Box 2591\n\n\n\nAbu Dhabi\n\n\n\nVereinigte
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)