use strict;
my $str = 'Hello hi_there@gmail.com, welcome to Gskinner!
Hello hi_there [at] gmail [dot] com, welcome to Gskinner!
Hello hi_there (at) gmail (dot) co (dot) uk, welcome to Gskinner!
Hello jam+jim @ googlemail.com, welcome to Gskinner!
Hello heythere {at} guardian [dot] co (dot) uk, welcome to Gskinner!
Hello contact [[[@]]] jazzit (dot) hr, welcome to Gskinner!';
my $regex = qr/[A-Z0-9\._%+-]+(\s*@\s*|\s*[\[|\{|\(]+\s*(at|@)\s*[\)|\}\]]+\s*)([A-Z0-9\.-]+(\.|\s*[\[|\{|\(]+\s*(dot|\.)\s*[\)|\}|\]]+\s*))+[a-z]{2,6}/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}