re = /[A-Z0-9\._%+-]+(\s*@\s*|\s*[\[|\{|\(]+\s*(at|@)\s*[\)|\}\]]+\s*)([A-Z0-9\.-]+(\.|\s*[\[|\{|\(]+\s*(dot|\.)\s*[\)|\}|\]]+\s*))+[a-z]{2,6}/mi
str = 'Hello hi_there@gmail.com, welcome to Gskinner!
Hello hi_there [at] gmail [dot] com, welcome to Gskinner!
Hello hi_there (at) gmail (dot) co (dot) uk, welcome to Gskinner!
Hello jam+jim @ googlemail.com, welcome to Gskinner!
Hello heythere {at} guardian [dot] co (dot) uk, welcome to Gskinner!
Hello contact [[[@]]] jazzit (dot) hr, welcome to Gskinner!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end