const regex = /\b[A-Z0-9._%+-]+(\s*@\s*|\s*[@\[\{\(]*(\s*(@)\s*|\s+([@\[\{\(]*at[\]\}\)]*)\s+)[\]\}\)]*\s*)([A-Z0-9-])+((\s*[\[\{\(]*\s*(dot|\.)\s*[\]\}\)]*\s*)+[A-Z]{2,6})+\b/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b[A-Z0-9._%+-]+(\\s*@\\s*|\\s*[@\\[\\{\\(]*(\\s*(@)\\s*|\\s+([@\\[\\{\\(]*at[\\]\\}\\)]*)\\s+)[\\]\\}\\)]*\\s*)([A-Z0-9-])+((\\s*[\\[\\{\\(]*\\s*(dot|\\.)\\s*[\\]\\}\\)]*\\s*)+[A-Z]{2,6})+\\b', 'gmi')
const str = `Hello hi_there@gmail.com, welcome to Gskinner!
Hello hi_there [at] gmail [dot] com, welcome to Gskinner!
Hello hi_there (at) gmail (dot) co (dot) uk, welcome to Gskinner!
Hello jam+jim @ googlemail.com, welcome to Gskinner!
Hello heythere {at} guardian [dot] co (dot) uk, welcome to Gskinner!
Hello contact [[[@]]] jazzit (dot) hr, welcome to Gskinner!
obfuscated_emails = [
"moo@doo.com",
"m_oo@doo.co.uk",
"moo @@ doo.com",
"moo @ doo . com",
"moo @ doo.com",
"moo@doo . com",
"moo@doo . co . uk",
"moo@doo. co. uk",
"m_oo @ doo.com",
"moo [at] doo.com",
"moo [at] doo . com",
"moo [at] doo [dot] com",
"m_oo [at] doo [dot] co [dot] uk",
"moo at doo.com",
"moo at doo . co . uk",
"m_oo at doo . com",
"moo at doo dot com"
]
Email him directly at firstname.lastname@companyname.com
word wordWithAtintheend. anotherword
roofcrafters-certifications.jpg , location.href
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}