use strict;
my $str = 'Hello hi_there@gmail.com, welcome to Gskinner!
Hello hi_there [at] gmail [dot] com, welcome to Gskinner!
Hello hi_there (at) gmail (dot) co (dot) uk, welcome to Gskinner!
Hello jam+jim @ googlemail.com, welcome to Gskinner!
Hello heythere {at} guardian [dot] co (dot) uk, welcome to Gskinner!
Hello contact [[[@]]] jazzit (dot) hr, welcome to Gskinner!
obfuscated_emails = [
"moo@doo.com",
"m_oo@doo.co.uk",
"moo @@ doo.com",
"moo @ doo . com",
"moo @ doo.com",
"moo@doo . com",
"moo@doo . co . uk",
"moo@doo. co. uk",
"m_oo @ doo.com",
"moo [at] doo.com",
"moo [at] doo . com",
"moo [at] doo [dot] com",
"m_oo [at] doo [dot] co [dot] uk",
"moo at doo.com",
"moo at doo . co . uk",
"m_oo at doo . com",
"moo at doo dot com"
]
Email him directly at firstname.lastname@companyname.com
word wordWithAtintheend. anotherword
roofcrafters-certifications.jpg , location.href
';
my $regex = qr/\b[A-Z0-9._%+-]+(\s*@\s*|\s*[@\[\{\(]*(\s*(@)\s*|\s+([@\[\{\(]*at[\]\}\)]*)\s+)[\]\}\)]*\s*)([A-Z0-9-])+((\s*[\[\{\(]*\s*(dot|\.)\s*[\]\}\)]*\s*)+[A-Z]{2,6})+\b/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}