# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b[A-Z0-9._%+-]+(\s*@\s*|\s*[@\[\{\(]*(\s*(@)\s*|\s+([@\[\{\(]*at[\]\}\)]*)\s+)[\]\}\)]*\s*)([A-Z0-9-])+((\s*[\[\{\(]*\s*(dot|\.)\s*[\]\}\)]*\s*)+[A-Z]{2,6})+\b"
test_str = ("Hello hi_there@gmail.com, welcome to Gskinner!\n"
"Hello hi_there [at] gmail [dot] com, welcome to Gskinner!\n"
"Hello hi_there (at) gmail (dot) co (dot) uk, welcome to Gskinner!\n"
"Hello jam+jim @ googlemail.com, welcome to Gskinner!\n"
"Hello heythere {at} guardian [dot] co (dot) uk, welcome to Gskinner!\n"
"Hello contact [[[@]]] jazzit (dot) hr, welcome to Gskinner!\n"
"obfuscated_emails = [\n"
" \"moo@doo.com\",\n"
" \"m_oo@doo.co.uk\",\n"
" \"moo @@ doo.com\",\n"
" \"moo @ doo . com\",\n"
" \"moo @ doo.com\",\n"
" \"moo@doo . com\",\n"
" \"moo@doo . co . uk\",\n"
" \"moo@doo. co. uk\",\n"
" \"m_oo @ doo.com\",\n"
" \"moo [at] doo.com\",\n"
" \"moo [at] doo . com\",\n"
" \"moo [at] doo [dot] com\",\n"
" \"m_oo [at] doo [dot] co [dot] uk\",\n"
" \"moo at doo.com\",\n"
" \"moo at doo . co . uk\",\n"
" \"m_oo at doo . com\",\n"
" \"moo at doo dot com\"\n"
"]\n"
"Email him directly at firstname.lastname@companyname.com\n"
"word wordWithAtintheend. anotherword\n"
"roofcrafters-certifications.jpg , location.href\n")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.