import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"[^\"]*(?:\"\"[^\"]*)*\"";
final String string = "\"Chiffre\",\"Nom\",\"Descriptif court\",\"Tarifs en clair\",\"Période en clair\",\"Adresse 1\",\"CP\",\"Tel\",\"\"\"Site\"\"\",\"Facebook\",\"Pictos\",\"@Saveurs\",\"@Famille plus\",\"@Img\",\"Accessible en fauteuil roulant en autonomie\",\"Handicapes\",\"Terrasse\",\"Wifi\",\"Chèque Vacances\",\"Titre Restaurant\"\n"
+ "6,\"Le Chalet d'en Ô\",\"Cuisine traditionnelle (foie gras, magret myrtilles, croustillant chocolat)\n"
+ "Spécialités savoyardes (fondue, tartiflette.. )\n"
+ "Garanti sans burgers.\n"
+ "Tout est fait maison.Cuisine traditionnelle (foie gras, magret myrtilles, croustillant chocolat)\n"
+ "Spécialités savoyardes (fondue, tartiflette.. )\n"
+ "Garanti sans burgers.\n"
+ "Tout est fait maison.\",\"Menu adulte : de 20 à 30 €\n"
+ "Menu enfant : 10 €.\n\n"
+ "Suggestion du jour le midi en semaine : entrée,plat, dessert : 20€.Menu adulte : de 20 à 30 €\n"
+ "Menu enfant : 10 €.\n\n"
+ "Suggestion du jour le midi en semaine : entrée,plat, dessert : 20€.\",\"Midi et soir du jeudi au samedi + midi le dimanche et jours fériés.\n"
+ "Juillet et août, midi et soir du mardi au samedi et midi uniquement dimanche et jours fériés.Midi et soir du jeudi au samedi + midi le dimanche et jours fériés.\n"
+ "Juillet et août, midi et soir du mardi au samedi et midi uniquement dimanche et jours fériés.\",\"Le Cropt - Route de Serraval\",\"74230 Les Clefs\",\"+33 4 50 02 09 00\",\"www.lechaletdeno.com\",,\"A R J X x\",,,,,\"A\",\"R\",\"J\",\"X\",\"x\"\n"
+ "7,\"La Cabane - Pisciculture de Montremont\",\"Bar - restaurant au bord de la rivière dans un cadre champêtre avec sa spécialité la truite.\",\"Menu adulte : de 26 à 35 €.\",\"Juin et septembre : du mercredi au dimanche.\n"
+ "Juillet et août : tous les jours à midi + mercredi à samedi le soir.Juin et septembre : du mercredi au dimanche.\n"
+ "Juillet et août : tous les jours à midi + mercredi à samedi le soir.\",\"Pisciculture de Montremont - 100 impasse des Pesetz\",\"74230 Thônes\",\"+33 4 50 02 00 85\",\"pisciculture-montremont.fr\",,\"A R X x\",,,,,\"A\",\"R\",,\"X\",\"x\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}