// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#""[^"]*(?:""[^"]*)*""#).unwrap();
let string = "\"Chiffre\",\"Nom\",\"Descriptif court\",\"Tarifs en clair\",\"Période en clair\",\"Adresse 1\",\"CP\",\"Tel\",\"\"\"Site\"\"\",\"Facebook\",\"Pictos\",\"@Saveurs\",\"@Famille plus\",\"@Img\",\"Accessible en fauteuil roulant en autonomie\",\"Handicapes\",\"Terrasse\",\"Wifi\",\"Chèque Vacances\",\"Titre Restaurant\"
6,\"Le Chalet d'en Ô\",\"Cuisine traditionnelle (foie gras, magret myrtilles, croustillant chocolat)
Spécialités savoyardes (fondue, tartiflette.. )
Garanti sans burgers.
Tout est fait maison.Cuisine traditionnelle (foie gras, magret myrtilles, croustillant chocolat)
Spécialités savoyardes (fondue, tartiflette.. )
Garanti sans burgers.
Tout est fait maison.\",\"Menu adulte : de 20 à 30 €
Menu enfant : 10 €.
Suggestion du jour le midi en semaine : entrée,plat, dessert : 20€.Menu adulte : de 20 à 30 €
Menu enfant : 10 €.
Suggestion du jour le midi en semaine : entrée,plat, dessert : 20€.\",\"Midi et soir du jeudi au samedi + midi le dimanche et jours fériés.
Juillet et août, midi et soir du mardi au samedi et midi uniquement dimanche et jours fériés.Midi et soir du jeudi au samedi + midi le dimanche et jours fériés.
Juillet et août, midi et soir du mardi au samedi et midi uniquement dimanche et jours fériés.\",\"Le Cropt - Route de Serraval\",\"74230 Les Clefs\",\"+33 4 50 02 09 00\",\"www.lechaletdeno.com\",,\"A R J X x\",,,,,\"A\",\"R\",\"J\",\"X\",\"x\"
7,\"La Cabane - Pisciculture de Montremont\",\"Bar - restaurant au bord de la rivière dans un cadre champêtre avec sa spécialité la truite.\",\"Menu adulte : de 26 à 35 €.\",\"Juin et septembre : du mercredi au dimanche.
Juillet et août : tous les jours à midi + mercredi à samedi le soir.Juin et septembre : du mercredi au dimanche.
Juillet et août : tous les jours à midi + mercredi à samedi le soir.\",\"Pisciculture de Montremont - 100 impasse des Pesetz\",\"74230 Thônes\",\"+33 4 50 02 00 85\",\"pisciculture-montremont.fr\",,\"A R X x\",,,,,\"A\",\"R\",,\"X\",\"x\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}