using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*(\""key\"":\""(\w*)\"")";
string input = @"blalasdl8ujd ""key"":""value"", blblabla asdw ""alo"":""ebobo"",blabla""www"":""zzzz""
blalasdl8ujd ""key"":""value"", blblabla asdw ""alo"":""ebobo"",blabla""www"":""zzzz""
blalasdl8ujd ""key"":""value"", blblabla asdw ""alo"":""ebobo"",blabla""www"":""zzzz""
blalasdl8ujd ""key"":""value"", blblabla asdw ""alo"":""ebobo"",blabla""www"":""zzzz""
blalasdl8ujd ""key"":""value"", blblabla asdw ""alo"":""ebobo"",blabla""www"":""zzzz""
blalasdl8ujd ""key"":""value"", blblabla asdw ""alo"":""ebobo"",blabla""www"":""zzzz"",""key"":""sdsfs"",
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}