package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([АВЕКМНОРСТУХавекмнорстухABEKMHOPCTYXabekmhopctyx]\s*\d{3}\s*[АВЕКМНОРСТУХавекмнорстухABEKMHOPCTYXabekmhopctyx]{2}\s*\d{2,3})|([АВЕКМНОРСТУХавекмнорстухABEKMHOPCTYXabekmhopctyx]{2}\s*\d{3}\s*\d{2,3})`)
var str = `+ а222aA22
+ A222Aa22
- а222ЛЮ22
- а22аа22
+ аа22222
+ аа222 22
+ аа222 222
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}