re = /([АВЕКМНОРСТУХавекмнорстухABEKMHOPCTYXabekmhopctyx]\s*\d{3}\s*[АВЕКМНОРСТУХавекмнорстухABEKMHOPCTYXabekmhopctyx]{2}\s*\d{2,3})|([АВЕКМНОРСТУХавекмнорстухABEKMHOPCTYXabekmhopctyx]{2}\s*\d{3}\s*\d{2,3})/m
str = '+ а222aA22
+ A222Aa22
- а222ЛЮ22
- а22аа22
+ аа22222
+ аа222 22
+ аа222 222
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end