#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).+?\.(cpp|h|txt|docx|xml)"
Local $sString = "wwww.txt" & @CRLF & _
"ddd.h" & @CRLF & _
"44444.cpp" & @CRLF & _
"data.xml" & @CRLF & _
"cpp.docx" & @CRLF & _
".profile" & @CRLF & _
".bat" & @CRLF & _
"cpp" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")