$re = '/.+?\.(cpp|h|txt|docx|xml)/m';
$str = 'wwww.txt
ddd.h
44444.cpp
data.xml
cpp.docx
.profile
.bat
cpp
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);