package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).+?\.(cpp|h|txt|docx|xml)`)
var str = `wwww.txt
ddd.h
44444.cpp
data.xml
cpp.docx
.profile
.bat
cpp
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}