using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*/bla-bla-bla/([^/.]+)\.a[0-9].*$";
string input = @"www.website.com/bla-bla-bla/this-is-the-word.a12345.anotherword.blabla";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}