// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.*/bla-bla-bla/([^/.]+)\.a[0-9].*$").unwrap();
let string = "www.website.com/bla-bla-bla/this-is-the-word.a12345.anotherword.blabla";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}