$re = '/^.*/bla-bla-bla/([^/.]+)\.a[0-9].*$/m';
$str = 'www.website.com/bla-bla-bla/this-is-the-word.a12345.anotherword.blabla';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);