#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\b[A-Za-z])\s*&\s*(?=[A-Za-z]\b)"
Local $sString = "A &B Should be replaced as AB" & @CRLF & _
"A& B Should be replaced as AB" & @CRLF & _
"A&B Should be replace as AB" & @CRLF & _
"ALPHA & B should not be matched. (Since ALPHA is a word)" & @CRLF & _
"ALPHA & BETA Should not be matched. (Since ALPHA & BETA both are words)"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)