$re = '/(\b[A-Za-z])\s*&\s*(?=[A-Za-z]\b)/m';
$str = 'A &B Should be replaced as AB
A& B Should be replaced as AB
A&B Should be replace as AB
ALPHA & B should not be matched. (Since ALPHA is a word)
ALPHA & BETA Should not be matched. (Since ALPHA & BETA both are words)';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;