import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\b[A-Za-z])\\s*&\\s*(?=[A-Za-z]\\b)";
final String string = "A &B Should be replaced as AB\n"
+ "A& B Should be replaced as AB\n"
+ "A&B Should be replace as AB\n"
+ "ALPHA & B should not be matched. (Since ALPHA is a word)\n"
+ "ALPHA & BETA Should not be matched. (Since ALPHA & BETA both are words)";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}