using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(%n)(?:([:+])(\d+)(?:(?!\2)([:+]\d+))?)?(?!\S)";
string input = @"%n:32+5000
%n:32
%n+5000
%n
%n+32:5000
%n+32
%n:5000
%n:32:5000
%n+32+5000";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}