re = /(%n)(?:([:+])(\d+)(?:(?!\2)([:+]\d+))?)?(?!\S)/m
str = '%n:32+5000
%n:32
%n+5000
%n
%n+32:5000
%n+32
%n:5000
%n:32:5000
%n+32+5000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end