$re = '/(%n)(?:([:+])(\d+)(?:(?!\2)([:+]\d+))?)?(?!\S)/m';
$str = '%n:32+5000
%n:32
%n+5000
%n
%n+32:5000
%n+32
%n:5000
%n:32:5000
%n+32+5000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);