import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^Cycle\\s+\\d+\\s+\\((\\d+)(?:\\s*\\w+\\s*(\\d+))?.*";
final String string = "Cycle 1 (0 h)\n"
+ "A\n"
+ "B\n"
+ "C\n"
+ "Cycle 2 (0 h 43 min)\n"
+ "A\n"
+ "B\n"
+ "C";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}