const regex = new RegExp('^Cycle\\s+\\d+\\s+\\((\\d+)(?:\\s*\\w+\\s*(\\d+))?.*', 'gm')
const str = `Cycle 1 (0 h)
A
B
C
Cycle 2 (0 h 43 min)
A
B
C`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}