re = /^Cycle\s+\d+\s+\((\d+)(?:\s*\w+\s*(\d+))?.*/m
str = 'Cycle 1 (0 h)
A
B
C
Cycle 2 (0 h 43 min)
A
B
C'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end