using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?!(jpeg|gif|png|pdf|jpg|css|js|woff|woff2|ttf)).)*$";
string input = @"/.well-known/acme-challenge/<TOKEN>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}