re = /((?!(jpeg|gif|png|pdf|jpg|css|js|woff|woff2|ttf)).)*$/m
str = '/.well-known/acme-challenge/<TOKEN>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end