using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"release\/v[1-9]?[0-9]\.[0-9](\.[0-9])?";
string input = @"release/v1.3.1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}