$re = '/release\/v[1-9]?[0-9]\.[0-9](\.[0-9])?/m';
$str = 'release/v1.3.1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);