use strict;
my $str = 'acestream://77f890b8dbc45e57bc145d0ee2c9eb381ff8e1ee acestream://ccba28e0ec6b5e09584dfcf80bcafa070bfe27b1 acestream://ad0de24741ba397708f6d4b0bc87a9e54a2c3331 acestream://679b815c666b89345ae5ef64a69203dec269f09f acestream://bec284c6636fd196bea5fc4186de96dfa94f79a1 acestream://d72ebe51dd14bad45ff011364ff06cd219795fc5 acestream://8c0b73b9ba6cc1b25195d5880f7c4796f007c7da acestream://2dfe474e6520f6015b8d2268476059756eb02d6e acestream://67ffc1f4f16b6b0b1f4113f76e37b6637249452c';
my $regex = qr/acestream://[a-zA-Z0-9]+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}