// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)acestream://[a-zA-Z0-9]+").unwrap();
let string = "acestream://77f890b8dbc45e57bc145d0ee2c9eb381ff8e1ee acestream://ccba28e0ec6b5e09584dfcf80bcafa070bfe27b1 acestream://ad0de24741ba397708f6d4b0bc87a9e54a2c3331 acestream://679b815c666b89345ae5ef64a69203dec269f09f acestream://bec284c6636fd196bea5fc4186de96dfa94f79a1 acestream://d72ebe51dd14bad45ff011364ff06cd219795fc5 acestream://8c0b73b9ba6cc1b25195d5880f7c4796f007c7da acestream://2dfe474e6520f6015b8d2268476059756eb02d6e acestream://67ffc1f4f16b6b0b1f4113f76e37b6637249452c";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}